To stop the reverse engineering of script apps, many developers encrypt their program code with instruments like ionCube PHP Encoder and make it human unreadable. The aforementioned is valid for paid apps in particular, since anybody would be able to use and change the unencrypted code without paying the needed license fees. When you obtain web software encrypted with ionCube PHP Encoder, you'll be able to use it without any problems as long as a software instrument known as ionCube Loader is available on the web hosting server. This loader allows you to run encoded files and you'll often find it as one of the prerequisites for a particular script application to be installed. Because the encrypted files are already precompiled, they are ordinarily executed faster and this can increase the general speed of your site.
IonCube in Hosting
When you get a hosting plan through our company, it will be created on our in-house built cloud hosting platform where ionCube Loader is already present, so you won't have any problems to run any script app that needs the instrument so as to function properly. In addition, we offer a few different versions of PHP, which means that in case you change the version, you will have to enable ionCube once again. Our system remembers the changes you make, which means that when you move back to the previous version of PHP which was active for your account, ionCube Loader will already be activated. The PHP version and the ionCube tool can be operated from the PHP Configuration section of our Hepsia web hosting Control Panel. Every adjustment that you do takes literally just a mouse-click and it takes effect at once.
IonCube in Semi-dedicated Servers
If you aquire a semi-dedicated server package from our company, you can take advantage of any kind of script-driven app which needs ionCube Loader due to the fact that the software tool is available on all the servers which are part of our modern cloud website hosting platform. We also support several releases of PHP, therefore if you move from PHP 4 to 5.2 or 5.3, for example, you can activate ionCube for this particular release with just a click from your Hepsia Control Panel. Our system will remember your choice, and if you move back to the previous release of PHP, the instrument will already be active. For more tech-savvy users, we also provide the option to select the PHP version and whether ionCube will be active or not for a specific domain without altering the settings for the whole hosting account. This can be done by placing a php.ini file inside a domain folder with a couple of lines of code.